OpenCore Legacy Patcher v1.4.3 黑苹果及老Mac电脑OpenCore综合驱动补丁工具

 

简介

OpenCore Legacy Patcher 由 Dortania 主导开发,一个基于 Python 的开源项目,围绕 Acidanthera 的 OpenCorePkg 和 Lilu,用于在受支持和不受支持的 Mac 上运行和解锁 macOS 中的功能。

项目的主要目标是为 Apple 不再支持的 Mac 注入新的活力,允许在 2007 年以前的机器上安装和使用 macOS Big Sur 和更新的 macOS 版本。

一些使用教程:

软件特性

  • 支持 macOS Big Sur、 Monterey、Ventura
  • 支持本机无线(Over The Air,OTA)系统更新
  • 支持 Penryn 和更新版本的 Mac(白苹果)
  • 在 BCM943224 和更新的芯片组上完全支持 WPA Wifi 和个人热点
  • 系统完整性保护、FileVault 2、.im4m 安全启动和存储
  • 在非原生操作系统上启动恢复操作系统、安全模式和单用户模式
  • 即使在 Mac(白苹果)上也能解锁 Sidecar 和 AirPlay 等功能
  • 在非标准硬件上启用增强的 SATA 和 NVMe 电源管理
  • 需要零固件补丁(即 APFS ROM 补丁)
  • Metal 和非 Metal GPU 的图形加速,目前已实现试验性支持 NVIDIA Kepler(GTX6x0)、Maxwell(GTX9x0)、Pascal(GTX10x0) 运行 Big Sur 和 Monterey。

「注意」

  • 本工具仅支持全新安装和升级 macOS,无法使用已使用其他修补程序(例如 Patched Sur 或 bigmac)修补的 macOS Big Sur 安装,因为 APFS 快照和 SIP 文件完整性以及受损。但是,你仍然可以使用此修补程序重新安装 macOS 并保留原始数据。
  • 目前 OpenCore Legacy Patcher 正式支持修补以运行 macOS Big Sur 和 Monterey 安装、Ventura安装。对于较旧的操作系统,OpenCore 可能会起作用,但 Dortania 目前不提供支持。

 

安装

  • OpenCore-Pacher-GUI.app:
    • 基于可视化 GUI 的应用程序
    • 推荐给所有用户
  • AutoPkg-Assets.pkg:
    • OpenCore-Patcher 使用的其他资源
    • 需要时自动拉取,请勿手动使用
  • 此为开源软件,直接将软件拖到应用程序目录即可;
  • 无需激活可直接使用,建议关闭自动更新以免激活失效(如果有);
  • 添加引导参数EFI/OC/config.plist
    # boot-args 位于 NVRAM 下 -> 7C436110-AB2A-4BBB-A880-FE41995C9F82下。
    amfi_get_out_of_my_way=0x1
    # AMFI 已启用 ngfxcompat=1
    # 强制缺少 compat 属性 ngfxgl=1
    # 强制 OpenGL 属性缺失 nvda_drv_vrl=1
    # nvda_drv(_vrl) 变量缺失
    # 要解决 SIP 错误,请将 csr-active-config 更改为030A0000
    # 重新启动后,从启动选择器中选择重置两次 NVRAM

更新日志 · 历史版本

[collapse title=“OpenCoreLegacyPatcher1.4.3”]

警告:升级到 12.7.4、13.6.5 或 14.4 可能会破坏旧版无线卡上的自动加入 WiFi 网络功能

要恢复自动加入支持,请忘记网络并重新添加。

这仅适用于旧版 WiFi 卡,包含在以下型号中:

  • MacBook5,x(2008 年初 - 2009 年初)
  • MacBookAir2,1 - MacBookAir3,x(2008 年中 - 2010 年末)
  • MacBookPro4,1 - MacBookPro7,1(2008 年末 - 2010 年中)
  • iMac7,1 - iMac12,x(2007 年中 - 2011 年中)
  • Macmini3,1(2009 年初 - 2009 年底)
  • MacPro3,1 - MacPro5,1(2008 年初 - 2012 年中)

随着 OpenCore Legacy Patcher v1.4.3 的发布,此版本主要针对 macOS 14.4/14.4.1 和配备非 Metal 显卡的 Mac。此版本解决了对以下具有非 Metal GPU 的机器的支持:

  • MacBook5,1 - MacBook7,1(2008 年初 - 2010 年中)
  • MacBookAir2,1 - MacBookAir4,x(2008 年中 - 2011 年中)
  • MacBookPro4,1 - MacBookPro8,x(2008 年末 - 2011 年末)
  • iMac7,1 - iMac12,x(2007 年中 - 2011 年中)
  • Macmini3,1 - Macmini5,x(2009 年初 - 2011 年中)
  • MacPro3,1 - MacPro5,1(2008 年初 - 2012 年中)

受影响的 GPU 型号

Vendor Architecture Generation
AMD TeraScale 1 and 2 2000 - 6000 series
Nvidia Tesla 8000 - 200 series
Nvidia Maxwell and Pascal 900 - 1000 series
Intel Iron Lake HD series
Intel Sandy Bridge HD 3000 series

正如预期的那样,macOS Sonoma 支持仍在积极开发中。这是一个社区驱动的项目,因此我们要求用户控制期望,并在遇到影响您的问题时使用较旧的操作系统。

完整变更日志

1.4.3 变更日志
  • 更新 macOS Sonoma 的非 Metal 二进制文件:
    • 解决 TeraScale 2 屏幕录制内核崩溃问题
    • 更改屏幕分辨率后解决 Dock 位置
    • 解决14.4登录窗口崩溃问题
  • 在原生支持 Monterey 或更新版本的 Mac 上修补 SkipLogo
    • 解决启动屏幕上丢失 Apple 徽标的问题
  • 增量二进制文件:
    • OpenCorePkg 0.9.9 - 发布资产信息
  • OpenCore-Patcher-GUI.app:
    • 基于可视化 GUI 的应用程序
    • 推荐给所有用户
  • AutoPkg-Assets.pkg:
    • OpenCore-Patcher 使用的其他资源
    • 需要时自动拉取,无需下载

[/collapse]

[collapse title=“OpenCoreLegacyPatcher1.4.2”]

警告 1:如果您拥有非 Metal Mac,请勿升级到 macOS 14.4

配备非 Metal 显卡的 Mac 目前不支持 macOS 14.4,请参阅macOS 14.4 非 Metal 会话错误 #1125了解更多信息。受影响的 Mac:

  • MacBook5,1 - MacBook7,1(2008 年初 - 2010 年中)
  • MacBookAir2,1 - MacBookAir4,x(2008 年中 - 2011 年中)
  • MacBookPro4,1 - MacBookPro8,x(2008 年末 - 2011 年末)
  • iMac7,1 - iMac12,x(2007 年中 - 2011 年中)
  • Macmini3,1 - Macmini5,x(2009 年初 - 2011 年中)
  • MacPro3,1 - MacPro5,1(2008 年初 - 2012 年中)
受影响的 GPU 型号

警告 2:如果升级到 macOS 14.4,您必须事先安装 OCLP 1.4.2。

许多硬件,包括 Metal GPU、WiFi 卡、T1 芯片组等都有针对 macOS 14.4 的新补丁。我们强烈建议您提前安装 OCLP 1.4.2 以确保顺利更新。

警告 3:升级到 12.7.4、13.6.5 或 14.4 可能会破坏旧版无线卡上的自动加入 WiFi 网络

要恢复自动加入支持,请忘记网络并重新添加。

这仅适用于旧版 WiFi 卡,包含在以下型号中:

  • MacBook5,x(2008 年初 - 2009 年初)
  • MacBookAir2,1 - MacBookAir3,x(2008 年中 - 2010 年末)
  • MacBookPro4,1 - MacBookPro7,1(2008 年末 - 2010 年中)
  • iMac7,1 - iMac12,x(2007 年中 - 2011 年中)
  • Macmini3,1(2009 年初 - 2009 年底)
  • MacPro3,1 - MacPro5,1(2008 年初 - 2012 年中)

随着 OpenCore Legacy Patcher v1.4.2 的发布,此版本主要针对 macOS 14.4 和所有 Mac,以确保功能正常。在 1.4.0 和 1.4.1 中,1.4.2 解决了现代无线卡上 WiFi 的自动加入问题、12.7.4 和 13.6.5 的传统 WiFi 支持以及 macOS Ventura 的 USB 1.1 回归问题。

正如预期的那样,macOS Sonoma 支持仍在积极开发中。这是一个社区驱动的项目,因此我们要求用户控制期望,并在遇到影响您的问题时使用较旧的操作系统。


完整变更日志

1.4.2 变更日志
  • 解决 macOS 14.4 上对 Modern Wireless 的自动加入支持问题
    • 适用于BCM94360、4360、4350、4331和43224芯片组
  • 解决 macOS 12.7.4 和 13.6.5 上旧版无线的 WiFi 支持问题
    • 适用于 BCM94328、BCM94322 和 Atheros 芯片组
  • 解决 macOS Ventura 上的 USB 1.1 从 OCLP 1.4.0 回归的问题
  • 增量二进制文件:
    • PatcherSupportPkg 1.4.8 - 发布
1.4.1 变更日志
  • 更新更新器实现
  • 解决运行 macOS 14.4 及更高版本的 MacBookAir6,x 的键盘/触控板支持问题
    • 扩展 SPI 键盘和触控板补丁以包括 MacBookAir6,x
  • 发布 BCM2046 和 BCM2070 芯片组的蓝牙 NVRAM 变量
    • 减少了 NVRAM 重置的需要,以恢复较新操作系统中的蓝牙支持(感谢@Ausdauersportler
1.4.0 变更日志
  • 重构子流程调用
  • 解决 RecoveryOS 支持(在 OpenCorePkg 中解决回归问题)
  • 恢复 macOS 14.4 及更高版本的 SPI 键盘和触控板支持
    • 适用于 MacBook8,1、MacBookAir7,x 和 MacBookPro12,1-14,x
  • 在 macOS 14.4 及更高版本上恢复对 T1 的支持
    • 适用于MacBookPro13,2,MacBookPro13,3,MacBookPro14,2,MacBookPro14,3
  • 在 macOS 14.4 及更高版本上恢复对旧版 Metal GPU 的支持
    • 适用于:
      • 通过 Skylake 的英特尔 Ivy Bridge
      • 英伟达开普勒
      • AMD 旧版 GCN
  • 在 macOS 14.4 及更高版本上恢复对 USB 1.1 的支持
    • 适用于 Penryn Mac、Xserve3,1 和 MacPro4,1/5,1
  • 解决 macOS 14.4 及更高版本上对传统和现代 WiFi 的支持
    • 适用于所有配备 WiFi 的 Mac 电脑
    • 14.4 的注意事项:在您忘记并重新加入网络之前,自动加入可能无法工作
  • 增量二进制文件:
    • OpenCorePkg 0.9.7 - 发布

资产信息

  • OpenCore-Patcher-GUI.app:
    • 基于可视化 GUI 的应用程序
    • 推荐给所有用户
  • AutoPkg-Assets.pkg:
    • OpenCore-Patcher 使用的其他资源
    • 需要时自动拉取,无需下载

[/collapse]

[collapse title=“OpenCoreLegacyPatcher1.4.1”]

警告 1:如果您拥有非 Metal Mac,请勿升级到 macOS 14.4

配备非 Metal 显卡的 Mac 目前不支持 macOS 14.4,请参阅macOS 14.4 非 Metal 会话错误 #1125了解更多信息。受影响的 Mac:

  • MacBook5,1 - MacBook7,1(2008 年初 - 2010 年中)
  • MacBookAir2,1 - MacBookAir4,x(2008 年中 - 2011 年中)
  • MacBookPro4,1 - MacBookPro8,x(2008 年末 - 2011 年末)
  • iMac7,1 - iMac12,x(2007 年中 - 2011 年中)
  • Macmini3,1 - Macmini5,x(2009 年初 - 2011 年中)
  • MacPro3,1 - MacPro5,1(2008 年初 - 2012 年中)
受影响的 GPU 型号
品牌 系列 型号
AMD TeraScale 1 和 2 2000 - 6000 系列
英伟达 特斯拉 8000-200系列
英伟达 麦克斯韦和帕斯卡 900 - 1000系列
英特尔 铁湖 高清系列
英特尔 珊迪大桥 高清3000系列

警告 2:如果升级到 macOS 14.4,您必须事先安装 OCLP 1.4.0。

许多硬件,包括 Metal GPU、WiFi 卡、T1 芯片组等都有针对 macOS 14.4 的新补丁。我们强烈建议您提前安装 OCLP 1.4.0 以确保顺利更新。

警告 3:升级到 14.4 可能会破坏自动加入 WiFi 网络

要恢复自动加入支持,请忘记网络并重新添加。

[/collapse]

[collapse title=“OpenCoreLegacyPatcher1.3.0”]

警告:在以下计算机上升级到 macOS 14.2 之前,您必须安装此更新:

  • MacBook Air
    • MacBookAir5,x(2012 年中)
    • MacBookAir6,x(2013 年中、2014 年初)
  • MacBook Pro
    • MacBookPro9,x(2012 年中)
    • MacBookPro10,x(2012 年中、2012 年末、2013 年初)
    • MacBookPro11,x(2013 年末、2014 年中)
  • Macmini电脑
    • Macmini6,x(2012 年末)
    • Macmini7,1(2014 年末)
  • iMac
    • iMac13,x(2012 年末)
    • iMac14,x(2013 年末、2014 年中)

受影响的显卡系列(所有基于 3802 的 Metal GPU):

  • Intel iGPUs
    • Ivy Bridge
    • Haswell
  • Nvidia dGPUs
    • Nvidia Kepler

随着 OpenCore Legacy Patcher v1.3.0 的发布,此版本主要针对 macOS 14.2 和配备基于 Metal 3802 显卡的 Mac。


完整变更日志

1.3.0 变更日志
  • 解决CFBundleExecutablekext 不匹配的二进制名称。
    • 解决 ProperTree 二元检测
    • 适用扩展:
      • corecrypto_T1.kext
      • corecaptureElCap.kext
      • IO80211ElCap.kext
  • 解决 macOS 14.2 Beta 2 及更高版本的 3802-GPU 支持问题。
    • 适用的GPU:
      • Intel Ivy Bridge 和 Haswell iGPU
      • Nvidia Kepler dGPU
  • 增量二进制文件:
    • PatcherSupportPkg 1.4.6 - 发布

[/collapse]

解压密码:imacos.top

资源下载
下载价格VIP专享
仅限VIP下载升级VIP
注册登录升级VIP会员 尊享全站资源下载特权
原文链接:https://imacos.top/2024/04/04/opencore-legacy-patcher-v1-4-3/,转载请注明出处。
2
1. 本站所有资源解压密码均为imacos.top
2. 本站资源收集于网络,仅做学习和交流使用,请于下载后24小时内删除。如果你喜欢我们推荐的软件,请购买正版支持作者。
3. 如有无法下载的链接,联系:邮箱271638927@qq.com,或直接联系QQ271638927进行反馈,我们将及时进行处理。
4. 本站发布的内容若侵犯到您的权益,请联系站长删除,联系方式:邮箱271638927@qq.com,我们将第一时间配合处理!

评论0

请先
终身会员限时上线 ☞ 限时永久会员折扣活动开始啦 > 查看优惠
显示验证码
没有账号?注册  忘记密码?

社交账号快速登录

微信扫一扫关注
如已关注,请回复“登录”二字获取验证码